Forum Thread: Fix for Slow Charging Issue

Fix for Slow Charging Issue

So guys, it's pretty well known the Nexus 7 has a painfully slow charging time. If you're using an aftermarket charger like me, it takes AGES to get the battery to 100%. Has the new 4.2.2 update solved this issue? A custom kernel of any help?

7 Responses

Hasn't been fixed; still sucks. I'd like to see if the dock helps.

Let's enumerate, please;

How long does it take to charge from 10% to 100% ?

What else does the tablet do while charging?

Is the screen on during charge?

If the screen is On, what brightness level is it at?

Is the device face up or face down during charge?

When you say charging is too slow, is it significantly slower than
Specification? Or, is it too slow to your liking?

Most of these questions point to factors that can heavily impact charging time.
The first and last questions are to establish ground rules for the discussion.

Mine just started with this problem... been charging now for about 7 hours and only climbed from 40 - 90 %!!! Most of the time it has been fully shut down during the charge... It's really, really annoying as I bought to go travelling and will be long periods away from a power source...

I find that if it's powered on during the charge (and I'm not using it) it charges quickly. However, if it's powered off during charge, I can leave it over night (7 to 9 hours) and only have it charge 70%.

i found out that the problem that cause the slow charging is the wire it comes along with it , if you are going to sleep ,put on the original wire i gives , but if you want quick charging i always use a wire which is shorter

But i don't know if the short wire will do any kind of damage to nexus 7 , so far so good , no over heating when charging and it's still running good , been doing this for 4 month

Had Nexus 7 tablet since August---never has worked right---always Wi- FI problems and now when I turn it on----all I get is a flashing white dot on the screen. I took it to the store where I bought and they plugged it and said I should return it to the manufacturer. The only address in book is Taiwan---looked for phone number on line---think he was in Taiwan---he gave me another phone number to call and it was disconnected. I guess I should have bought a Kindle. Does anybody know how I can get this tablet working or return it?

judy ann , in reply to your question it sounds like you have a very common problem that thousands of nexus 7 users have encountered, what you do is remove the back so the battery etc is exposed and if you look at where the USB plugs in to the charge port on the unit look at that now look up at the battery and you will see like a plug that the wires from the battery plug into, this socket offer works its way loose, you basically just push it back in or pull it out and then push it back in, thousands of units had this problem causing whit screen slow charge etc, my unit has a ridiculously slow slow charge I've had it on all night and this morning it has 7% charge (so annoying) my unit has either got a dud battery or the USB port needs changing, I have an app which shows me the milli amp voltage that is going into or out of the battery so when the charger is not plunged in it reads around -100 to -600, when I plug the charger in it should read + 400 to +600 or more but it doesn't it jumps around an most of the time it reads -100 to -400 an if I push the USB in again it may go up to +400\+500 an charge nicely but if I touch the leed it drops to -100 odd so its very hard to get a charge going, I disable all apps turn WiFi / GPS/ Bluetooth off I turn the screen brightness down to minimum so I know its none of that, also I have factory reset it to make sure it wasn't some rouge app causing it but nothing makes a difference, so anyway in your case the battery plug socket being pushed back in properly should solve your problem, unfortunately my issue is something different that lots of us are experiencing that has no fix yet other than using the dock to charge it then its fine . My nexus 7 holds charge great but getting it to charge is a bitch...,I hope this has helped so basically take off the back and push the battery plug socket into its port more and it should solve your problem

Share Your Thoughts

  • Hot
  • Active